CP2 Web Server Not Loading Websites Correctly

Incident Report for RS Host

Resolved

All websites have now been restored to our other servers. If you are experiencing any issues with your site please log a support ticket via the support portal and we will address any issues.
Posted Mar 26, 2026 - 10:32 UTC

Update

We now have 90% of sites restored and back up and running. We are continuing to work on restoring the remaining websites.
Posted Mar 25, 2026 - 06:39 UTC

Update

We are still working on restoring accounts to alternative servers in the background at the moment.
Posted Mar 24, 2026 - 03:05 UTC

Update

Having replaced the raid controller there is still a hardware issue with the system. At this point we are awaiting a Dell engineer to arrive at the data centre with replacement parts. The ETA for this is tomorrow, Tuesday 24th March.

In the mean time, we are working to restore affected accounts to one of our other servers. Please note - if your DNS is not with RS Host then we will reach out to you to manually update your DNS to point to the new servers IP address.
Posted Mar 23, 2026 - 21:28 UTC

Update

Our team are continuing to work on the server outage and will post any further updates on here shortly.
Posted Mar 23, 2026 - 18:22 UTC

Identified

We have identified the cause of the outage to be due to a faulty raid controller on the CP2 Server.
Our engineers are currently en route to the data centre to perform a replacement on the faulty hardware.
We will update this page as we have any new information.
Posted Mar 23, 2026 - 13:56 UTC

Investigating

We are currently investigating an issue with websites not loading on the CP1 web server.
Posted Mar 23, 2026 - 09:20 UTC
This incident affected: Web Hosting Services (London - CP2 Webserver).